Opened 8 years ago

Closed 8 years ago

#4461 closed Bug (fixed)

Combo boxes make the toolbar be heigher with Office2003 skin & RTL mode on IE

Reported by: Sa'ar Zac Elias Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.1
Component: UI : Toolbar Version:
Keywords: Oracle Confirmed Review+ Cc: senthil.kumaran@…

Description

when adding combobox to the toolbar, the line is getting heighr and the background is being duplicated. it happens with the Office 2003 skin with RTL mode and IE6 & 8, couldn't check on 7.
to reproduce:
generate an editor with a toolbar containes, for example, FontSize or TextColor. also make sure you are using Office2003 skin and RTL mode. then, look at the toolbar and notice that the row is bigger and there is a start of a new background just underneath.
*attached an image to explain.

Attachments (2)

ckebug.PNG (6.3 KB) - added by Sa'ar Zac Elias 8 years ago.
notice the area marked in red
4461.patch (1009 bytes) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by Sa'ar Zac Elias

Attachment: ckebug.PNG added

notice the area marked in red

comment:1 Changed 8 years ago by Senthil

Keywords: Oracle added
Milestone: CKEditor 3.1

This issue is happening to us also when we have the '-' between the dropdown toolbar controls. Please see the example below.

Ex: CKEDITOR.config.toolbar = [

['Templates','-','Styles','Format','Font','FontSize']

]

comment:2 Changed 8 years ago by Senthil

Cc: senthil.kumaran@… added

comment:3 Changed 8 years ago by Garry Yao

Keywords: Confirmed added

The issue is even reproduced without the RTL config.

Manual TCs added at : http://ckeditor.t/tt/4461/1.html

Changed 8 years ago by Garry Yao

Attachment: 4461.patch added

comment:4 Changed 8 years ago by Garry Yao

Component: GeneralUI : Toolbar
Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:6 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [4570].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy