Opened 8 years ago

Closed 7 years ago

#4487 closed Bug (fixed)

FCKEditor 2.6.5 Does Not work with Safari 3.2.1

Reported by: Ruben Gamez Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.6.6
Component: General Version: FCKeditor 2.6.5
Keywords: Confirmed Safari Review+ Cc:

Description

I just updated to FCKEditor 2.6.5 to fix a height issue with Safari 4, but now Safari 3.2.1 doesn't display anything in the editor -- I also can't type anything in there.

This was working without any problems on both versions of Safari before the update. I'm using the replace text field method in case it helps. Don't hesitate to email me for more information.

Attachments (2)

proposal-section.png (30.5 KB) - added by Ruben Gamez 8 years ago.
Screenshot of issue
4487.patch (1019 bytes) - added by Frederico Caldeira Knabben 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by Ruben Gamez

Attachment: proposal-section.png added

Screenshot of issue

comment:1 Changed 8 years ago by Domen Mali

Hi,

i had the same problem. i review all the changes in my svn and found a "bug/solution".

in file "fckeditor.html (line 270) and fckeditor.original.html (line 378)" in "fckeditor/editor" folder

If i change

if ( FCKBrowserInfo.IsGecko || FCKBrowserInfo.IsSafari )

to

if ( FCKBrowserInfo.IsGecko && !FCKBrowserInfo.IsOpera )

FCK works again in Safari 3.2.1, but i guess that in Safari 4 the height problem appears again.

comment:2 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Resolution: wontfix
Status: newclosed

It's not possible to download Safari 3 from http://www.apple.com/safari/download/ so testing such environments isn't easy as they would require to keep some system with updates disabled

The described change is not feasible as that would mean that now IE also might execute that code, and if we leave that aside and only consider Opera and Safari, testing for IsOpera is the same that checking for IsSafari.

comment:3 in reply to:  2 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Confirmed Safari added
Milestone: FCKeditor 2.6.6
Resolution: wontfix
Status: closedreopened

Replying to alfonsoml:

It's not possible to download Safari 3 from http://www.apple.com/safari/download/

Here you have it, for Leopard, Tiger and Windows.

Testing such environments isn't easy as they would require to keep some system with updates disabled

That's true... but it looks like we have options for it:
http://michelf.com/projects/multi-safari/

In fact I was able to reproduce and confirm the bug.

The described change is not feasible as that would mean that now IE also might execute that code, and if we leave that aside and only consider Opera and Safari, testing for IsOpera is the same that checking for IsSafari.

True... I'll be providing a patch for it.

Changed 7 years ago by Frederico Caldeira Knabben

Attachment: 4487.patch added

comment:4 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Review? added
Owner: set to Frederico Caldeira Knabben
Status: reopenednew

I'm proposing the same version detection code we use on V3.

comment:5 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

Those links are interesting. I've heard too many times of IE Tester but I never show this option for Safari, and virtualising Mac OS X isn't too easy (as it's expensive to buy the Server version).

comment:6 Changed 7 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [5123].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy