Opened 12 years ago

Closed 12 years ago

#457 closed Bug (invalid)

Chinese characters

Reported by: Sandrine Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4.2
Keywords: Pending WorksForMe Cc:

Description

Hi,

I have installed tikiwiki here: http://www.paysans-sans-frontieres.com/wiki/ I have been using Internet Explorer 6 and add a bug with fckeditor. When I wrote a text and edited the text again, there add Chinese characters showing in the page. I have updated Internet Explorer to version 7, and the Chinese characters have disappeared, but I now have squares.

Those strange characters appear when I write French, with a combination of é, à, è. All those letters are changed into Chinese.

I have tried forums, updates, etc... etc... but the problem still be here.

I also have a problem with the administration of WYSIWYG, as it is said in Tikiwiki that fckeditor comes with an admin, while there is not any in the Tikiwiki Administration tools: http://doc.tikiwiki.org/tiki-index.php?page=Wysiwyg+Editor+Admin&bl

Expecting your help, I send you my bests regards.

Sandrine

Change History (3)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Pending WorksForMe added

We don't have problems here. Please try our online demo and see if you have problems there. It if works there, then the problem is somewhere else, but not in the editor. Also, I see no Chinese at all there, only question marks.

I believe that there is some place in your installation that is not working with UTF-8. Check your database settings and the page which processes the post. You may also check it with Tikiwiki.

comment:2 in reply to:  1 Changed 12 years ago by Sandrine

Hi fredck,

Hi have tested the demo and here is the result:

<p>je dois tester l'&eacute;diteur pour v&eacute;rifier qu'il fonctionne avec les accents</p>

It changes the french accents into caracters.

Do you have an answer for the WYSIWYG's administration page ? It does not show in tikiwiki.

Expecting your answer, I send you my bests regards, Sincerely,

Sandrine

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: invalid
Status: newclosed

Accented characters are converted to their relative HTML entities. This is the expected behavior. You can disable it in the configuration settings (ProcessHTMLEntities=false).

For TikiWiki issues, I can't tell you anything regarding it. You should contact them directly (http://tikiwiki.org/).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy