Opened 12 years ago

Closed 8 years ago

#460 closed Bug (wontfix)

when putting style="border:1px solid black; border-top:0px" in an elemint, it puts a mozilla specific CSS attribute for one of the values

Reported by: Frank M Thompson Owned by: Martin Kou
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4.2
Keywords: Firefox Confirmed CantFix Cc:

Description

when putting style="border:1px solid black; border-top:0px" in an elemint, it puts a mozilla specific CSS attribute for one of the values. For instance putting this: style="style="border:1px solid black; border-top:0px"

results in:

style="border-style: none solid solid; border-color: -moz-use-text-color black black; border-width: 0px 1px 1px;"

which is fine if you are viewing the page in FF, but in IE the border color is off. I tried to use the nightly build to test to see if it was fixed, but the nightly build wouldn't even load for me or for another person I asked to view. Sorry if its a dupe.

Change History (5)

comment:1 in reply to:  description Changed 12 years ago by Alfonso Martínez de Lizarrondo

Keywords: Firefox Confirmed added; CSS border removed

Replying to sirmeili:

I tried to use the nightly build to test to see if it was fixed, but the nightly build wouldn't even load for me or for another person I asked to view. Sorry if its a dupe.

Ops, that's my fault, I've commited a patch to fix it. But it won't change this bug.

Your problem is surely in the Gecko engine itself like https://bugzilla.mozilla.org/show_bug.cgi?id=229092 You should try to search for a bug in bugzilla and if the problem persists with latest alpha of Firefox 3 then you should report a bug there so they can fix it.

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: CantFix added
Milestone: FCKeditor 2.6

I don't see chances to solve this one at our side, as for the editor those style rules are simply there. There is no way to catch that Mozilla added it automatically.

We must file a bug at Mozilla's Bugzilla for this one. I'm targeting this job to 2.6.

comment:3 Changed 12 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

I think this should have been fixed with the patch to #617, still awaiting review.

comment:4 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.6FCKeditor 2.7

Re-targeting to the 2.7 together with #617.

comment:5 Changed 8 years ago by Krzysztof Studnik

Resolution: wontfix
Status: assignedclosed

Expired

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy