Opened 8 years ago

Closed 8 years ago

#4642 closed Bug (fixed)

Invalid HTML causes infinite loop in IE

Reported by: Wiktor Walc Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: FCKeditor 2.6.6
Component: General Version: FCKeditor 2.6.5
Keywords: Confirmed Review+ Cc:

Description

This bug was introduced here: http://dev.fckeditor.net/ticket/2156

In IE, paste the following content in the source mode:

<p id="1"><strong></span></p>
<p id="2"><strong></span></p>
<p id="3"><strong></span></p>
<p id="4"><strong></span></p>
<p id="5"><strong></span></p>
<p id="6"><strong></span></p>
<p id="7"><strong></span></p>
<p id="8"><strong></span></p>
<p id="9"><strong></span></p>
<p id="10"><strong></span></p>
<p id="11"><strong></span></p>
<p id="12"><strong></span></p>
<p id="13"><strong></span></p>
<p id="14"><strong></span></p>
<p id="15"><strong></span></p>
<p id="16"><strong></span></p>
<p id="17"><strong></span></p>
<p id="18"><strong></span></p>
<p id="19"><strong></span></p>
<p id="20"><strong></span></p>
<p id="21"><strong></span></p>
<p id="22"><strong></span></p>

then switch back to wysiwyg, press source button again - IE hangs and enters an infinite loop, after a while it asks whether script execution should be stopped.

The problem is caused by FCKXHtml._RemoveXHtmlJobProperties() function in fckxhtml_ie.js.

Attachments (1)

4642.patch (1015 bytes) - added by Alfonso Martínez de Lizarrondo 8 years ago.
Proposed patch

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Alfonso Martínez de Lizarrondo

Attachment: 4642.patch added

Proposed patch

comment:1 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review? added
Milestone: FCKeditor 2.6.6
Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

comment:2 Changed 8 years ago by Wiktor Walc

Keywords: Review+ added; Review? removed

Looks reasonable and fixed the issue for me.

comment:3 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: assignedclosed

Fixed with [5113]

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy