Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#4666 closed Bug (fixed)

IE - selection is not visible when context menu is opened

Reported by: Wiktor Walc Owned by: Garry Yao
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IBM WorksForMe IE Cc: Satya Minnekanti, joek, Damian

Description

To reproduce:

  • select some text
  • right-click your mouse to open the context menu

Result: selection is not visible (but if you choose "copy", the content is copied properly).

This bug does not occur in FCKeditor. Confirmed in IE6, IE7 and IE8.

Attachments (1)

4666.patch (3.3 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2

We could try to understand how V2 handles the context menu, but I think there is no easy way for that as much probably this works well there because we use IE popups, not floating iframes like in V3.

If no easy fix could be found for the 3.2, the only solution would be having the selection styled while the context menu is opened, just like we do for the find dialog.

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

#4723 has been marked as DUP.

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2CKEditor 3.3

comment:4 Changed 7 years ago by Garry Yao

If no easy fix could be found for the 3.2, the only solution would be having the selection styled while the context menu is opened, just like we do for the find dialog.

AFAIK that's the only way for it...

Changed 7 years ago by Garry Yao

Attachment: 4666.patch added

comment:5 Changed 7 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

The patch emulates the blurred selection mark of other browsers on IE.

comment:6 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.3CKEditor 3.4

comment:7 Changed 7 years ago by Garry Yao

#5760 has been marked as DUP.

comment:8 Changed 7 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:9 Changed 7 years ago by Sa'ar Zac Elias

Cc: Satya Minnekanti joek Damian added; satya_minnekanti@… removed

#5947 has been marked as DUP.

comment:10 Changed 7 years ago by Sa'ar Zac Elias

Keywords: WorksForMe added; Confirmed removed

I can not reproduce the bug anymore on the current trunk.

comment:11 Changed 7 years ago by Joe Kavanagh

Keywords: IBM added

This bug can not be reproduced from revision 5667 onwards. It appears to have been fixed indirectly.

comment:12 Changed 7 years ago by Sa'ar Zac Elias

Keywords: Review? removed
Milestone: CKEditor 3.4
Resolution: fixed
Status: assignedclosed

Great, feel free to open the ticket again for any new discovery.

comment:13 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Funny. I was a little afraid while doing the change to mark the contextmenu as unselectable because it could have some drawback with regards to accesibility, but instead it has fixed this problem.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy