Opened 9 years ago

Closed 9 years ago

#4679 closed Bug (fixed)

Badly nested inline styles are not being preserved by the parser

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Normal Milestone: CKEditor 3.1
Component: General Version: SVN (CKEditor) - OLD
Keywords: Pending Cc:

Description

  1. Load the following HTML in the editor:
<p>Line 1</p>
<b>
    <p>Line 2</p>
    <p>Line 3</p>
    <p>Line 4</p>
</b>
<p>Line 5</p>
  1. Switch to WYSIWYG and back to source

Expected output:

<p>
	Line 1</p>
<p>
	<b>Line 2</b></p>
<p>
	<b>Line 3</b></p>
<p>
	<b>Line 4</b></p>
<p>
	Line 5</p>

Current output:

<p>
	Line 1</p>
<p>
	<b>Line 2</b></p>
<p>
	Line 3</p>
<p>
	Line 4</p>
<p>
	Line 5</p>

This is a regression. It works well with the 3.0.1.

Change History (2)

comment:1 Changed 9 years ago by Garry Yao

Keywords: Pending added; Confirmed removed

Unable to confirm on trunk with TC:
http://ckeditor.t/tt/4679/1.html.

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Works for me with the current trunk also. It may have been fixed recently in another ticket (#4656 ?).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy