Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#4720 closed Bug (wontfix)

CKEDITOR.dom.element.createFromHtml fails on style element in IE

Reported by: Scott González Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE Cc:

Description

CKEDITOR.dom.element.createFromHtml fails to create style elements in IE. I've tested in IE6 and IE8; Safari and Firefox worked as expected.

The following code throws an error because the temp div does not contain any HTML after the call to .setHtml() in .createFromHtml():

CKEDITOR.dom.element.createFromHtml( '<style type="text/css">p { color: green; }</style>');

Change History (2)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Version: 3.0.13.0

Problem has been reproducible in IE6-8 from CKEditor 3.0.

Just execute the above code in console or insert it in page in instanceReady event.

Message: 'getFirst()' is empty or not an object
Line: 73
URI: /3.6.4/ckeditor/_source/core/dom/element.js

comment:2 Changed 5 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: confirmedclosed

The only supported browser which fail on this is IE8 (it works well on IE9). We don't want to make the code more complex because of this, so I think it's time to close this ticket.

Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy