Opened 9 years ago

Closed 9 years ago

#4740 closed Bug (fixed)

CKLangTool does not recognize entries in single quotes

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Confirmed Review+ Cc:

Description

As the title says. CKLangTool does not recognize properly entries in single quotes, like for example:

	colors :
	{
		'000' : 'Schwarz',
		'800000' : 'Kastanienbraun',
		'8B4513' : 'Braun',
		'2F4F4F' : 'Dunkles Schiefergrau',
		'008080' : 'Blaugrün',
	...

such entries are replaced with english words.

This issue will be fixed in #3698, because a new way of loading/parsing files will be introduced there.

Attachments (2)

langtool.jar (877.3 KB) - added by Wiktor Walc 9 years ago.
4740.patch (16.8 KB) - added by Wiktor Walc 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by Wiktor Walc

German translation of colors added with [4579].

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Hum... I think #3698 got some changes in the way it was going... maybe a specific fix for it is necessary here.

Changed 9 years ago by Wiktor Walc

Attachment: langtool.jar added

Changed 9 years ago by Wiktor Walc

Attachment: 4740.patch added

comment:3 Changed 9 years ago by Wiktor Walc

Keywords: Review? added

Added ((?:'|\")?) + backwards reference in some expressions to catch quotes.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 9 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

Fixed with [4659].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy