Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#4844 closed Bug (fixed)

IE: dialogs don't work when running many editors on the same page

Reported by: Wiktor Walc Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: CKEditor 3.5.4
Component: General Version: 3.0.1
Keywords: IE Cc: drendall@…, mikko.kinnunen@…

Description

Confirmed on IE7/IE8. Fortunately, this issue happens only when running a lot of editors at the same page (like 25-30+).

IE shows this error:

Not enough storage is available to complete this operation.

Attachments (2)

ajax.html (2.7 KB) - added by Alfonso Martínez de Lizarrondo 7 years ago.
Modified sample file
4844.patch (1.3 KB) - added by Alfonso Martínez de Lizarrondo 7 years ago.
Proposed patch

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

comment:2 Changed 8 years ago by Daniel Rendall

Cc: drendall@… added

There seems to be some discussion around this issue here: http://cksource.com/forums/viewtopic.php?f=6&t=17318

Here's some Microsoft documentation that says that there's a limit (31) to the number of stylesheets which can be created using createStyleSheet http://msdn.microsoft.com/en-us/library/ms531194%28VS.85%29.aspx

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.x

Milestone CKEditor 3.x deleted

Changed 7 years ago by Alfonso Martínez de Lizarrondo

Attachment: ajax.html added

Modified sample file

comment:4 Changed 7 years ago by Alfonso Martínez de Lizarrondo

This sample file allows to create as many editors as desired (destroy will work only on the last one, this is just for a quick test).

With this test, it seems that if a dialog is open before the maximum number of stylesheets is reached, then it works correctly later, but it isn't very interesting to force the load of dialog.css before it's ever used. Anyway, this must be kept in mind for other tests.

Applying a change as described in http://cksource.com/forums/viewtopic.php?p=51044#p51044 it's possible to load 33 editors in IE and then being able to open a dialog. It's very slow, but everybody knows that IE is slow.

So the following patch might not solve all the problems, but at least it's able to increase the limits and delay the error.

Changed 7 years ago by Alfonso Martínez de Lizarrondo

Attachment: 4844.patch added

Proposed patch

comment:5 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Owner: set to Alfonso Martínez de Lizarrondo
Status: confirmedreview

comment:6 Changed 7 years ago by Mikko Kinnunen

Cc: mikko.kinnunen@… added

Sorry to just "bump" this bug but it seems there is working patch that has been forgotten.

This is major issue for some of our sites and while we currently work around it by manual patching it would be great to have the proper fix included.

comment:7 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.5.4
Status: reviewreview_passed

comment:8 Changed 6 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: review_passedclosed

Fixed with [6723]

comment:9 Changed 6 years ago by Eugene Mirotin

Hi. The fix doesn't work for me. We are using the most recent version (3.6.2) and there's single instance of CKEditor on the page. The problem is in IE8

To see it reproduced: go to http://mtv-flux.epam.com/QA/dev/rita/rpxQA_2.html using the bar at the bottom, click Sign in link, use your Facebook or Twitter account to log in, refresh the page Then click your name shown in the bar (in place of Sign in link) In the overlay shown click My Content tab, and then Add Blog Post blue button on the right This dynamically loads the ckeditor.js script, then initializes the editor instance

In IE8 the error is shown in lots of cases, and when it isn't it is shown later when you try to add the link

comment:10 Changed 6 years ago by Jakub Ś

Well what if someone like me for example does not have neither Twitter nor Facebook account or simply does not want to use those accounts to log into your pages.

Would be nice if you could provide us with test login/pass to your application.

Second - the fact that issue occurs in your application does not mean that this is CKEditor fault. It can also concern your custom application settings that collide with CKEditor. I think it would be best if you could provide a sample file(s) (E.g. HTML page), a reduced test case that shows the problem and can be used with freshly downloaded CKEditor.

@emirotin are you able to reproduce this problem outside of your application? If so, please open a new ticket (as this one is closed) , attach this file there and explain what are the steps to reproduce the problem (Of course it can be marked that new ticket is continuation of this one).

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy