Opened 10 years ago

Closed 8 years ago

#4846 closed Bug (duplicate)

Opera: object becomes unselected when context menu is opened

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: UI : Context Menu Version: 3.4.1
Keywords: Opera Cc:

Description

When selecting an image, right-clicking with a mouse and opening image properties, all values are empty. Tested on Opera 10.10 (build 1893) @ XP/SP3.

Steps to reproduce

  • Start with the following source
    <p>This is s<img alt="" src="http://a.cksource.com/c/1/inc/img/opensource-110x95.gif" style="width: 214px; height: 44px" />ome <strong>sample text</strong></p>
    
  • click on an image
  • right-click to open the context menu (note: when using Shift+F10, this problem does not exist)
  • result: dialog is opened, but image properties are missing

Change History (6)

comment:1 Changed 10 years ago by Wiktor Walc

Version: 3.0.1SVN (CKEditor)

Actually this does not happen in 3.0.1 because context menu was not working there, so changing version to SVN.

comment:2 Changed 10 years ago by Wiktor Walc

Some extra notes:

  • does not happen when editing links,
  • after closing the context menu, before switching to source mode, if you click on the text you'll see that the element path is invalid: "body p" has changed into "body p p".

comment:3 Changed 9 years ago by Krzysztof Studnik

Version: SVN (CKEditor) - OLD3.4.1 (SVN - trunk)

On Opera 10.61.3484, CKE 3.4.1 Trunk, confirming of this issue is blocked by #5395

comment:4 Changed 9 years ago by Krzysztof Studnik

Component: GeneralUI : Context Menu

comment:5 Changed 9 years ago by Garry Yao

Supposed to be fixed by #5395.

comment:6 Changed 8 years ago by Hallvord R. M. Steen (Opera Software)

Resolution: duplicate
Status: confirmedclosed

WFM, so probably fixed by #5395 - marking dup

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy