Opened 8 years ago

Closed 8 years ago

#4924 closed Bug (fixed)

PHP integration is not using the timestamp in the ckeditor.js script

Reported by: Frederico Caldeira Knabben Owned by: Wiktor Walc
Priority: Normal Milestone: CKEditor 3.1
Component: Server : PHP Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc:

Description

According to the documentation, the server side scripts must append the timestamp to the ckeditor.js file, so it updates the cache on new releases. The PHP integration is not currently doing so.

Attachments (1)

4924.patch (1.9 KB) - added by Wiktor Walc 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 years ago by Wiktor Walc

Owner: set to Wiktor Walc

Changed 8 years ago by Wiktor Walc

Attachment: 4924.patch added

comment:2 Changed 8 years ago by Wiktor Walc

Keywords: Review? added

The attached patch does two things:

  • "%TIMESTAMP%" is changed into "%"."TIMESTAMP%" to prevent against replacing this value by CKReleaser - we don't want to add "%TIMESTAMP%" to the query string in the SVN version
  • !empty($this->timestamp) was removed because CKEDITOR.timestamp = ''; should appear on the page even if timestamp is empty (this way config.js and other files are loaded without appended timestamp)

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:4 Changed 8 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

Fixed with [4863].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy