Opened 8 years ago

Closed 4 years ago

#4990 closed Bug (wontfix)

fckdtd2js failing

Reported by: Jonathan Neal Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I've been trying to build my own DTD for CKEditor, but FCKdtd2js.jar does not appear to be working properly. I receive the following error:

>java -jar FCKdtd2js.jar dtd\html401-strict.dtd
At line 81, column 8: Expected GT instead of NMTOKEN(--)
com.wutka.dtd.DTDParseException: At line 81, column 8: Expected GT instead of NMTOKEN(--)
        at com.wutka.dtd.DTDParser.expect(DTDParser.java:311)
        at com.wutka.dtd.DTDParser.parseEntityDef(DTDParser.java:916)
        at com.wutka.dtd.DTDParser.parseEntity(DTDParser.java:818)
        at com.wutka.dtd.DTDParser.parseTopLevelElement(DTDParser.java:262)
        at com.wutka.dtd.DTDParser.parse(DTDParser.java:121)
        at com.wutka.dtd.DTDParser.parse(DTDParser.java:103)
        at net.fckeditor.devutil.dtd.WutkaDTDParser.parseXmlDefinition(WutkaDTDParser.java:30)
        at net.fckeditor.devutil.dtd.DTDJsGenerator.run(DTDJsGenerator.java:137)
        at net.fckeditor.devutil.dtd.DTDJsGenerator.main(DTDJsGenerator.java:95)

You can also follow this thread for more information.

http://cksource.com/forums/viewtopic.php?f=11&t=15566

Attachments (1)

html401-strict.dtd (34.9 KB) - added by Alfonso Martínez de Lizarrondo 8 years ago.
slightly fixed dtd

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by Alfonso Martínez de Lizarrondo

Attachment: html401-strict.dtd added

slightly fixed dtd

comment:1 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: fckdtd2js removed
Version: SVN (CKEditor)

The problem isn't the FCKdtd2js.jar tool, but the fact that the html401-strict.dtd is not a valid XML document. You can compare with the version that I've uploaded that by fixing the syntax it can go on processing the data. With enough time it should be possible to provide a fixed .dtd for HTML 4.01 and XHTML 1.1

comment:2 Changed 8 years ago by Jonathan Neal

Priority: NormalHigh

So the SVN repository of FCKdtd2js can't actually convert a single known DTD file? And the official DTD files should be considered "invalid" by this DTD tool?

Also, the "xhtml11.dtd" contains an escaped HTML file, not the official DTD.

comment:3 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Priority: HighNormal

The FCKdtd2js is just a tool. Even after using it you'll need to edit the output code manually. If it can't parse those .dtd it means that no one has cared about them.

You can adjust them as I started to do or create your own tool that it's able to handle them in the current way.

comment:4 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: Confirmed added

comment:5 Changed 4 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: confirmedclosed

FCKdtd2js is no longer supported.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy