Opened 8 years ago

Closed 2 years ago

#5049 closed Bug (fixed)

Form Field list in JAWS lists Rich Text editor field wrongly.

Reported by: Pranav Prakash Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.2
Component: Accessibility Version: SVN (CKEditor) - OLD
Keywords: Oracle Cc: Senthil, Pranav

Description

Press Insert+F5 to display the form field list. Jaws lists CKEditor as Unlabeled1 Edit and Unlabeled2 Edit.

Attachments (3)

JAWS_CKEditor.png (31.1 KB) - added by Pranav Prakash 8 years ago.
Jaws Error with CKEditor
RTE_JAWS_Oracle.PNG (30.0 KB) - added by Pranav Prakash 7 years ago.
Oracle Version
RTE_JAWS_Nightly.PNG (35.6 KB) - added by Pranav Prakash 7 years ago.
Nightly Build

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by Pranav Prakash

Attachment: JAWS_CKEditor.png added

Jaws Error with CKEditor

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

We have now better result in the aria branch. Can you please check it there?

comment:2 Changed 8 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned

Regression of [4563] where the focus grabber hack in IE was unexpectedly treated as form fields in JAWS.
Supposed to be fixed with [4981] on aria branch.

comment:3 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed
Version: 3.1SVN (CKEditor)

Fixed with [5092] in 3.2.x branch.

Changed 7 years ago by Pranav Prakash

Attachment: RTE_JAWS_Oracle.PNG added

Oracle Version

Changed 7 years ago by Pranav Prakash

Attachment: RTE_JAWS_Nightly.PNG added

Nightly Build

comment:4 in reply to:  2 Changed 7 years ago by Pranav Prakash

Replying to garry.yao:

Regression of [4563] where the focus grabber hack in IE was unexpectedly treated as form fields in JAWS.
Supposed to be fixed with [4981] on aria branch.

The fix suggested by you removes the duplicate entry for CKEditor in Form Field list in Jaws but it still shows editor as Unlabeled1 Edit. However in nightly build, Jaws lists the editor as Rich Text Editor. Please refer to screenshots attached below.

Oracle Codeline: http://dev.fckeditor.net/raw-attachment/ticket/5049/RTE_JAWS_Oracle.PNG Nightly Build: http://dev.fckeditor.net/raw-attachment/ticket/5049/RTE_JAWS_Nightly.PNG

Please provide a patch to fix the above mentioned issue in Oracle codeline. Also observe that in nightly build, all toolbar controls are listed in form field list by JAWS but not in Oracle codeline. Is this behavior correct for nightly build? Also on selecting a toolbar control from form field list in Jaws, the toolbar control is not actually getting activated in nightly build. It seems to be a bug. Can you please investigate this issue too?

comment:5 Changed 7 years ago by Garry Yao

Adding new comment to a closed ticket is not the right way for supporting request, it could easily passes unnoticed because it's a closed ticket .

comment:6 in reply to:  5 Changed 7 years ago by Pranav Prakash

Resolution: fixed
Status: closedreopened

Replying to garry.yao:

Adding new comment to a closed ticket is not the right way for supporting request, it could easily passes unnoticed because it's a closed ticket .

Ok...So I am re-opening the ticket. Please provide us the patch in our codeline.

comment:7 Changed 7 years ago by Garry Yao

Please instead use our email support channel for such requests.

Please provide a patch to fix the above mentioned issue in Oracle codeline

If you're using one of our reversion on ARIA branch, we strongly suggest you to update your package to 3.2, since ARIA features are tightly coupled between changesets, it would be hard to us to figure out which combination of patches bring one feature, for example this one.

Also observe that in nightly build, all toolbar controls are listed in form field list by JAWS.Is this behavior correct for nightly build?

Yes.

Also on selecting a toolbar control from form field list in Jaws, the toolbar control is not actually getting activated in nightly build.

JAWS is able to recognize the toolbar buttons and we're currently presenting all the buttons in ARIA, so we consider it as a JAWS limitation.

comment:8 Changed 2 years ago by Jakub Ś

Cc: Senthil Pranav added; Senthil Pranav removed
Resolution: fixed
Status: reopenedclosed

I can see that starting from CKEditor 3.2 as well as in latest CKEditor 4.4.7 editor is labelled

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy