Ticket #5057 (closed Bug: invalid)

Opened 4 years ago

Last modified 2 years ago

IE: BACKSPACE may delete the entire paragraph with corrupt HTML

Reported by: fredck Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.5
Keywords: IE Cc:

Description

  1. With FCKeditor and IE, load the following HTML:
<P>X</P><SPAN>
<P></SPAN>Put the caret in the middle of this paragraph and hit BACKSPACE.</P>
<P>Y</p>
  1. Just follow the instructions, by placing the caret at the middle of the second paragraph.
  1. Hit BACKSPACE.

The entire paragraph is deleted.

Change History

comment:1 Changed 4 years ago by garry.yao

WFM in v3.

comment:2 Changed 2 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to invalid

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy