Opened 8 years ago

Closed 8 years ago

#5095 closed Bug (fixed)

CKEditor: Safari deletes selected text when browser Edit menu is clicked

Reported by: rgm Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: CKEditor 3.2
Component: Core : Pasting Version: 3.1
Keywords: Confirmed Safari Mac Cc: technology@…

Description (last modified by Frederico Caldeira Knabben)

  1. Select text in CKEditor on Safari on a Mac.
  2. Click Safari's Edit menu.

The selected text disappears.

Change History (5)

comment:1 Changed 8 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Keywords: Confirmed Safari Mac added
Milestone: CKEditor 3.3

Confirmed on Mac only.

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

The problem is that Safari is firing the "beforepaste" event when clicking the "Edit" menu. I've opened a ticket for it at WebKit:
https://bugs.webkit.org/show_bug.cgi?id=34894

We may try using "beforepaste" in the clipboard plugin on WebKit, otherwise we'll need a browser fix.

comment:3 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Component: GeneralCore : Pasting
Owner: set to Alfonso Martínez de Lizarrondo

The patch in #4988 fixes the problem using the "paste" event instead of "beforepaste"

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.3CKEditor 3.2

comment:5 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: newclosed

Fixed with [5118]

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy