Opened 9 years ago

Closed 9 years ago

#5106 closed Bug (duplicate)

IE8 Scroll Bar/Cursor Problem

Reported by: John Jackson Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (CKEditor) - OLD
Keywords: Pending Cc: john.jackson@…

Description

To replicate:

  1. In IE8, open nightly build demo (specifically 'Replace textareas by class name').
  2. Paste in a lot of text (doesn't seem to matter what, I tried a few tests with different copy). I used a Lorem Ipsum generator and pasted in about 30 paragraphs.
  3. Now make sure the cursor is at the top of the text, and scroll down (using scroll bar) to near the bottom of the text.
  4. Click into the text to attempt to set the cursor position.
  5. You will probably find the cursor jumps back up to the previous position. If not, try again as it doesn't seem to consistently fail, but does so perhaps 9/10 times.

It seems to happen whenever the cursor needs to be set to a position significantly higher or lower then the current cursor position.

This seems specific to IE8 only (using compatibility mode seems to fix it), the version I have is 8.0.7600.16385 (64-bit).

The nightly build I'm testing on now is 5048.

Change History (4)

comment:1 Changed 9 years ago by John Jackson

Cc: john.jackson@… added

comment:2 Changed 9 years ago by Garry Yao

Keywords: Pending added

I was unable to reproduce it no trunk.
Duplicate of #4762 and is supposed to be fixed at [5008].

comment:3 Changed 9 years ago by John Jackson

I've done a screencast so you can see the issue:

http://www.screencast.com/t/NzBmNDYw

(keep an eye on the scroll bar jumping back up/down on the RHS, this is when I'm trying to place the cursor).

I'm not sure it is the same bug as #4762 or #5008, the issues seem to be similar but as it's not fixed presumably this bug is different.

A couple of users reported this problem to me, hence why I've filed this bug, so it is definitely a problem, at least in my implementation and on your demo.

Thanks!

comment:4 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Resolution: duplicate
Status: newclosed

dup of #4817

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy