Opened 10 years ago

Closed 7 years ago

#5136 closed Bug (fixed)

JAWS is not reading disabled tool bar controls as "Unavailable Link" in Firefox

Reported by: Pranav Prakash Owned by:
Priority: Normal Milestone: CKEditor 3.2
Component: Accessibility Version: 3.1
Keywords: Oracle Cc: Senthil, Pranav

Description

Press Alt+F10 to enable tool bar controls. Keep pressing Tab until you reach a disabled control e.g. Undo or Redo. You will observe that JAWS is reading it as "Undo" or "Redo" not as "Undo-Unavailable Link" or "Redo-Unavailable Link" as it does in Internet Explorer 8. This issue was reproducible in Firefox 3.6.

Change History (3)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.2
Resolution: fixed
Status: newclosed

This feature is now implemented through ARIA in the 3.2, and we're not willing to have hacks to deal with it. It's currently working well with FF 3.6. also.

comment:2 in reply to:  1 Changed 10 years ago by Pranav Prakash

Resolution: fixed
Status: closedreopened

Replying to fredck:

This feature is now implemented through ARIA in the 3.2, and we're not willing to have hacks to deal with it. It's currently working well with FF 3.6. also.

Recently we have upgraded to CKEditor 3.1 and right now we don't have any plans for upgradation to CKEditor 3.2. Since it's a accesibility issue, it's a high priority item for us. Can you please provide us a patch for our code line? We uptook the CKEditor at revision number 5018. I am reopening this ticket for the patch.

comment:3 Changed 7 years ago by Jakub Ś

Resolution: fixed
Status: reopenedclosed

This issue was fixed in CKE 3.2 and works in CKE 3.6.3. I'm closing this ticket since it was 2 years since last comment.

If you still need this for version 1, please reopen this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy