Opened 9 years ago

Closed 6 years ago

#5138 closed Bug (wontfix)

Naming convention mistakes in dialogs' tabs

Reported by: Sa'ar Zac Elias Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.1
Keywords: Cc:

Description

Some dialogs have naming convention mistakes in the tabs - these might confuse the developer.
in my opinion it's for the best that all tab names will be lowercase and using toLowerCase() in dialog definition events when trying to remove or get tabs.
a list of what i've fond:

  1. 'advanced' in all dialogs
  2. 'info' in all dialogs
  3. 'find' & 'replace' in find dialog
  4. 'properties' in flash dialog
  5. 'target' & 'upload' in link dialog
  6. 'options', 'langs', 'ditionaries' & 'about' in SCAYT dialog

Some more mistakes, yet minor since it is the only tab there:

  1. 'tab1' in about, smiley & uicolor dialogs
  2. 'general' in clipboard, pasetext & wsc dialogs
  3. 'picker' in color dialog
  4. 'selectTpl' in template dialog

Change History (3)

comment:1 Changed 8 years ago by Sa'ar Zac Elias

Milestone: CKEditor 3.5.1
Status: newconfirmed

This is now in priority because of #5915.
Let's make the configuration introduced with #5915 case insensitive.
Note that we must keep backwards compatibility regarding changes of this ticket'''

comment:2 Changed 8 years ago by Garry Yao

Milestone: CKEditor 3.5.1
Status: confirmedpending

I can't see this a problem and seeing unnecessary to reinforce lowercase unless our codes are affected by this problem somewhere, it's more a user preference of the dialog field identifier.

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: pendingclosed

This indeed is not a good practise that we don't have a standard naming convention. However, it is now impossible to change those names, because of backward compatibility.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy