Opened 10 years ago

Closed 10 years ago

#520 closed Bug (fixed)

Select Field doesn't accept values with &

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.4.3
Component: General Version:
Keywords: Confirmed, IE Cc: support.fckeditor@…

Description

When editing the properties of a select field, options which the text and values have ampersands, with no spaces near it, are not applied and retrieved correctly.

This is a IE only issue. Works well with Firefox.

Steps to reproduce

  1. Open the Select Field dialog;
  2. Add an option with text and values set to "1&2". You will not that the values will not show correctly in the list;
  3. Click ok in the dialog;
  4. Check the source. You will have <option value="1&amp;2" selected="selected">1</option> (to note "1" as innerHTML).

Change History (4)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [332].

Click here for more info about our SVN system.

comment:2 Changed 10 years ago by George M. Harkin

Resolution: fixed
Status: closedreopened

Looks like this is happening with urls too

  1. Highlight some text
  2. Click url button.
  3. Select protocol as "other", type in "/file & name.jpg"
  4. Click "OK"

View the source, you will see an &amp; is inserted into the href attribute.

comment:3 Changed 10 years ago by George M. Harkin

Oh, mah bad!

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy