Opened 10 years ago

Closed 10 years ago

#5234 closed Bug (invalid)

Div container's context menu does not work for divs that are created via source

Reported by: Sa'ar Zac Elias Owned by:
Priority: Normal Milestone:
Component: General Version: 3.1
Keywords: Cc:

Description

To reproduce

  • Open a new editor and switch to source mode
  • Insert this code:
    <div>Text</div>
    
  • Go to WYSIWYG mode and right-click inside the div

The div container's context menu does not work.

Change History (1)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: invalid
Status: newclosed

This is by design. The fact is that we're talking about "containers". In the exemplified HTML the <div> there is acting more like a paragraph than a container.

Inside CKEditor we consider a container only divs that contain other block elements. For example, the context menu will work if you load the following:

<div>
    <p>Text</p>
</div>

In this case we can safely remove the container and the contents will still fit well in the document structure. It's just a conceptual matter.

In the way you're describing it, you are instead looking for a generic element editor, which can change properties of "any" element, including divs. We're not talking about a container anymore. This feature should be handled in a different ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy