Opened 6 years ago

Closed 3 years ago

#5241 closed Bug (fixed)

Inserted tag <p>&nbps;</p> on format "normal" insead replacing tag

Reported by: lordxor Owned by:
Priority: Normal Milestone:
Component: General Version: 3.1
Keywords: Cc:

Description

If changing format of new empty line (eg. <p>&nbsp</p>), instead of replacing tag is inserted new <p>&nbsp;</p>. Happends in FF 3.6 and Opera 10.10 .

1) You have empty CKEditor
2) Write on first line letter "a", enter, second line "b"
3) Insert new empty line between letter "a" and "b" - http://www.soft-4u.eu/ckeditor/Step3.png
4) On this new empty line choose from formats "h1"
5) Then choose "Normal" format for 3 times
6) Looks like nothing changes, but choose "source". There will be inserted <p>&nbsp;</p>. http://www.soft-4u.eu/ckeditor/Step6.png
7) Back from source to editing, you will see updated edit area, new line appears. http://www.soft-4u.eu/ckeditor/Step7.png


8) You can go to new empty line, which was create in step 3) and repeat steps till 7). Again, new <p>&nbsp;</p> inserted.

Attachments (3)

Step3.png (31.9 KB) - added by lordxor 6 years ago.
Step6.PNG (44.6 KB) - added by lordxor 6 years ago.
Step7.PNG (48.7 KB) - added by lordxor 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by lordxor

Changed 6 years ago by lordxor

Changed 6 years ago by lordxor

comment:1 Changed 3 years ago by j.swiderski

  • Resolution set to fixed
  • Status changed from new to closed

No longer reproducible.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy