Opened 9 years ago

Closed 9 years ago

#5259 closed Bug (fixed)

FF 3.6 https/ssl Issue

Reported by: Tim Fluehr Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: SVN (CKEditor) - OLD
Keywords: Firefox Confirmed Review+ Cc:

Description

In Firefox 3.6 you receive the "Contains unauthenticated content" warning.

I tracked the issue down and it looks like it is coming from the following on line 291 of 'ckeditor/_source/plugins/wysiwygarea/plugin.js' (version 3.2).

' src="javascript:void(function(){' + encodeURIComponent( srcScript ) + '}())"' +

Changing that line to the following resolves the error, but probably causes other problems in other browsers because it is no longer includes 'srcScript'

' src="javascript:false;"' +

Attachments (1)

5259.patch (1.4 KB) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by Garry Yao

Keywords: Firefox Pending added; ssl https firefox removed

Works for me on Firefox3.6 on Windows7 with HTTPS on trunk, any other evidence?

comment:2 Changed 9 years ago by Tim Fluehr

I don't have trunk downloaded, but I confirmed in the nightly build (Revision number: 5211) that it is an issue viewing the samples using FF3.6 on win 7. I also was able to reproduce using the portable versions of FF3.5 and FF3.0 on Windows XP.

comment:3 Changed 9 years ago by Tim Fluehr

Let me know if there is anything specific you want me to look for or test.

comment:4 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Confirmed added; Pending removed

Changed 9 years ago by Garry Yao

Attachment: 5259.patch added

comment:5 Changed 9 years ago by Garry Yao

Owner: set to Garry Yao
Status: newassigned
Version: 3.2SVN (CKEditor)

Unbelievable right? Yet another fix for HTTPS warning, we've already lost the regression tracking info but it seems that [5109] is the one - that document.open() is the culprit of this HTTPS warning in Firefox :/

comment:6 Changed 9 years ago by Garry Yao

Keywords: Review? added

comment:7 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

I'm a little worried about the change with regards to domain relaxation, but it seems to be working fine in my little tests.

comment:8 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5242].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy