Opened 10 years ago

Closed 10 years ago

#5312 closed Bug (wontfix)

When selected content has more than one paragraph format, paragraph format list box always showing the paragraph format option of the first selected line of text

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2
Keywords: IBM Cc: joek, Damian

Description (last modified by Frederico Caldeira Knabben)

To reproduce the defect

  1. Open ajax sample
  1. Type few lines of text(say 6) and apply diff Paragraph formattings(Heading 1 to Heading 6) to each line.
  1. select all the content and look for the fomatting option displayed in Pragraph Format list box.

Actual: Paragraph Format list box displays the Paragraph format option of the Top line in the selected content

Expected: Paragraph Format list box should not display any option, since the selected text has diff paragraph format option applied.

Same issues also happens with Font Name, Font Size and Styles drop down lists

Change History (4)

comment:1 Changed 10 years ago by Satya Minnekanti

Milestone: CKEditor 3.3

comment:2 Changed 10 years ago by Garry Yao

Keywords: Pending added

I guess you're meaning the opposite "Expected" and "Actual" here?

comment:3 Changed 10 years ago by Satya Minnekanti

Garry you are right.Just a typo in the error.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Keywords: Pending removed
Milestone: CKEditor 3.3
Resolution: wontfix
Status: newclosed

This is by design. The toolbar will be always sensitive to the start of the selection only. Any change in this sense will have drastic impact on the editor performance.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy