Opened 10 years ago

Closed 6 years ago

#5325 closed Bug (fixed)

Path becomes relative after a copy / paste

Reported by: Ollea Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Firefox VendorFix Cc:

Description

If you are accessing CKEditor with an URL ending with a slash, let's say :

http://ckeditor.com/demo/

Insert a new link in the editor and specify "http://ckeditor.com/test/" (please note the ending slash) as URL.

Then select the newly created link and copy / paste it.

Now have a look at the source, the link becomes :

<a href="../test/">...

Even if you specify the config baseHref.

How can we fix this ?

Change History (8)

comment:1 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Milestone: CKEditor 3.3
Priority: HighNormal

comment:2 Changed 10 years ago by Ollea

Priority: NormalHigh

I think this bug must be defined as a high priority because the resulting URLs (after a copy / paste) are broken.

comment:3 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Priority: HighNormal

If you provide a patch then you can set the priority that you want. Meanwhile I guess that this is a browser bug that will be hard to fix.

comment:4 Changed 10 years ago by Ollea

Yes, you are right, this is a browser specific bug, I thought it could be solved more easily. I will check if I can fix it.

comment:5 Changed 8 years ago by aeon

Related to #193, still blocked by firefox bug https://bugzilla.mozilla.org/show_bug.cgi?id=295930

comment:6 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Changes in copy/paste will be fixed in Firefox 12 according to https://bugzilla.mozilla.org/show_bug.cgi?id=613517

comment:7 Changed 8 years ago by Jakub Ś

Keywords: Firefox VendorFix added
Status: newconfirmed
Version: 3.23.0

To reproduce:

  1. Create page with code like (you can use ip or domain):
    <div contenteditable="true">
    	<a href="http://192.168.1.150:8595/index.html">Link1</a>	
    	<img src="http://192.168.1.150:8595/someimage.jpg">
    </div>
    
  2. Open it in Firefox and copy links and images
  3. Paste them into CKEditor

Result: Firefox will chnage absolute URLs to:

<a href="../../../../../index.html">Link1</a> <br />
<img src="../../../../../b.jpg" /> <br />

comment:8 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

This issue has been fixed in Firefox and I can't reproduce it in CKEditor anymore.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy