Opened 8 years ago

Closed 7 years ago

#5329 closed Bug (duplicate)

maximize will error if button is not displayed

Reported by: Eddie Wyatt Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2
Keywords: HasPatch Cc:

Description

Request for improvement. I would like an option to maximize the ckeditor control by default.

You can simulate that by using

CKEDITOR.on('instanceReady', function(ev) {

var editor = ev.editor; editor.execCommand('maximize');

});

However you'll get a javascript error if the maximize button is not part of the current tool bar. This can fixed if the following change is made to the maximize plugin.

if (button) {

var buttonNode =

editor.element.getDocument().getById(button._.id);

buttonNode.getChild(1).setHtml(label); buttonNode.setAttribute('title', label); buttonNode.setAttribute('href', 'javascript:void("' + label + '");');

}

Change History (2)

comment:1 Changed 8 years ago by Alfonso Martínez de Lizarrondo

Keywords: HasPatch added; maximize removed

comment:2 Changed 7 years ago by Wiktor Walc

Resolution: duplicate
Status: newclosed

Duplicate of #6166 (actually this issue is 6 months older, so obviously the other ticket was a duplicate of this one).

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy