Opened 5 years ago

Closed 3 years ago

#5339 closed Bug (expired)

In fullpage mode, document without "title" tag breaks CKEditor

Reported by: benh Owned by: m.nguyen
Priority: Normal Milestone:
Component: General Version: 3.2
Keywords: HasPatch Cc:

Description

To reproduce:

  1. create an editor with the "fullpage" option turned on.
  1. start editing content in WYSIWYG mode.
  1. switch to source mode and adjust the content so that there is no title tag in the head.
  1. switch back to WYSIWYG mode, note that the toolbar buttons don't come back to being usable.

Patch:

Patch for plugins/wysiwygarea/plugin.js (at least, here's the diff that fixes it for us):

741,744c741,742
<                                         if (title != null) {
< 						title.setAttribute( '_cke_title', editor.document.$.title );
< 						editor.document.$.title = frameLabel;
<                                         }
---
> 					title.setAttribute( '_cke_title', editor.document.$.title );
> 					editor.document.$.title = frameLabel;

Attachments (1)

5339.patch (530 bytes) - added by m.nguyen 5 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by alfonsoml

  • Keywords HasPatch added; fullpage removed

Changed 5 years ago by m.nguyen

comment:2 Changed 5 years ago by m.nguyen

  • Keywords Review? added
  • Owner set to m.nguyen
  • Status changed from new to assigned

comment:3 Changed 5 years ago by matti

Related #5338 ?

comment:4 Changed 5 years ago by wwalc

  • Keywords HasPatch added; HasPatch? removed
  • Status changed from review to assigned

comment:5 Changed 5 years ago by wwalc

  • Status changed from assigned to pending

Works for me in trunk.

comment:6 Changed 3 years ago by j.swiderski

  • Resolution set to expired
  • Status changed from pending to closed

WFM as well.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy