Opened 10 years ago

Closed 10 years ago

#538 closed Bug (fixed)

FF: Style/format/font/size dropdown only works once

Reported by: Geir Helge Tjøstolvsen-Schmidt Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6
Component: UI : Toolbar Version: FCKeditor 2.4.2
Keywords: Cc:

Description

FireFox:

  • Click somewhere inside the wysiwyg body to place the cursor somewhere in the text.
  • Click on the Format dropdown arrow. The format dropdown appears, as expected.
  • Click on the Format dropdown arrow. The format dropdown disappears, as expected.
  • Click on the Format dropdown arrow as many times as you want; the dropdown never re-appears.

This also applies to the style-, font- and size dropdowns.

Also tested with nightly build today

Change History (9)

comment:1 Changed 10 years ago by Geir Helge Tjøstolvsen-Schmidt

Forgot to say that you'll have to change the cursor position or use another function in the toolbar in order to reactivate the dropdown.

comment:2 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Pending added

Sorry, but I can't reproduce it. The behavior that I see on second click is as described in #347: the dropdown closes and immediately appears again.

Tested in Firefox 2.0.4 in Windows and Mac

comment:3 Changed 10 years ago by Geir Helge Tjøstolvsen-Schmidt

Seems like this might be a problem only on Debian like OS? This is our test results:

Ubuntu Feisty with FF 2.0.4: As described in this bug
Debian with FF 2.0.4: As described in this bug

WinXP with IE6: As described in bug 347
WinXP with IE7: As described in bug 347
WinXP with FF 2.0.4: As described in bug 347

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Pending removed
Milestone: FCKeditor 2.6
Priority: LowNormal

Still haven't confirmed it, but targeting to the 2.6 for investigation.

comment:5 Changed 10 years ago by Martin Kou

It seems to affect the Linux version of Firefox only. I can see the bug occurring in Firefox 1.5.0.12 in CentOS 5.

comment:6 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:7 Changed 10 years ago by Martin Kou

The second click to the combo box shouldn't close the floating panel at all, and so the issue starts at the second click, not the third click - the third click is just repeating what happened at the second click.

The patch to #1514 seems to fix this at the first glance, but another problem props out: now the floating panel wouldn't close at the second click (which is correct). But if you clicked elsewhere after the second click, the panel wouldn't close. I'm rewriting #1514's patch to fix this ticket as well.

comment:8 Changed 10 years ago by Martin Kou

I've uploaded a revised patch to #1514 which fixes this ticket as well.

comment:9 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with #1514.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy