Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#5399 closed Bug (fixed)

Lists pasted from Word do not maintain their nesting

Reported by: Charles O'Sullivan Owned by: Paweł Horzela
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.1
Keywords: Cc: satya_minnekanti@…

Description

After copying a Word document from Word 2007 to CKEditor, a list with nested lists inside it flattens out. This occurs for both numbered and unordered lists.

Steps to Reproduce

  1. Create a Word document which has a nested list inside.
  1. Copy the list using CTRL+C.
  1. Go to CEditor and open "Paste from Word"
  1. Paste the document into the dialog's textarea and click "OK"

I do not know if this issue occurs with other versions of Word. I have created a patch which seems to solve the problem.

Attachments (3)

pastefromword.patch (1.2 KB) - added by Charles O'Sullivan 8 years ago.
Patch for fixing nested lists from Word documents
This is a line of text.doc (27.0 KB) - added by Charles O'Sullivan 8 years ago.
Word document with nested list which which does not maintain nesting when pasted into CKEditor.
5399.patch (1.1 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (16)

Changed 8 years ago by Charles O'Sullivan

Attachment: pastefromword.patch added

Patch for fixing nested lists from Word documents

Changed 8 years ago by Charles O'Sullivan

Attachment: This is a line of text.doc added

Word document with nested list which which does not maintain nesting when pasted into CKEditor.

comment:1 Changed 8 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:2 Changed 7 years ago by Wiktor Walc

Status: newconfirmed

Confirmed using Office 2010 and IE8 @ Vista.

comment:3 Changed 7 years ago by Wiktor Walc

Version: 3.1

Looks like a regression, introduced in 3.1.

comment:4 Changed 7 years ago by Paweł Horzela

Owner: set to Paweł Horzela
Status: confirmedassigned

comment:5 Changed 7 years ago by Wiktor Walc

The exact configuration when I was able to reproduce it: Win 7 Professional N 64-bit EN + Office 2010 standard (en_office_standard_2010_x64_515548.exe)

comment:6 Changed 7 years ago by Wiktor Walc

The attached patch works for me.

comment:7 Changed 7 years ago by Paweł Horzela

It's caused by unit of measurement settings in MS Word. It doesn't work only for inches.

To change settings, please go to: File -> Options -> Advanced -> Display -> Show measurements in units of

comment:8 Changed 7 years ago by Paweł Horzela

Attached patch also fixes this issue.

comment:9 Changed 7 years ago by Paweł Horzela

Status: assignedreview

comment:10 Changed 7 years ago by Wiktor Walc

Component: GeneralCore : Pasting

Changed 7 years ago by Garry Yao

Attachment: 5399.patch added

comment:11 Changed 7 years ago by Garry Yao

Status: reviewreview_passed

The patch is good except for the last chunk of change adding 'list-style-type'.

comment:12 Changed 7 years ago by Paweł Horzela

Resolution: fixed
Status: review_passedclosed

Fixed with [5934]

comment:13 Changed 4 years ago by Frederico Caldeira Knabben

Component: Core : PastingPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy