Opened 9 years ago

Closed 9 years ago

#5408 closed Bug (fixed)

Style plugin not working as expected.

Reported by: Gilles van den Hoven Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (CKEditor) - OLD
Keywords: Cc:

Description

Assigning a 'block style' to the CKEditor is not working when; a) The current content is not wrapped in a block. b) All content is selected.

Steps to reproduce:

  • remove wrapping "<P>" tag from any sample file which has the style plugin.
  • SelectAll or use CTRL+A to select all content.
  • Set the style to a 'block' style.

Expected behaviour:

  • The block style applied to the entire selected text.

Given result:

  • No changes to the selection, although the 'style' combo shows the selected style (untill you click somewhere else).

---

Also tried intercepting CTRL+A (by config.keystrokes) and assigning 'SelectAll' has no effect.

Clicking inside the line which you want to make a certain style (or selecting a word inside that line), and then choosing the style DOES work like expected, but when all content is selected it does not work.

Change History (1)

comment:1 Changed 9 years ago by Gilles van den Hoven

Resolution: fixed
Status: newclosed

Fixed in latest SVN, at least there it is working as it should; is this due to changeset 5240?

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy