Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#5423 closed New Feature (fixed)

Add config option for DefaultLinkTarget

Reported by: Charlie Shehadi Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Confirmed Doc Cc:

Description

The DefaultLinkTarget option used to be in FCKEditor, but it's not in CKEditor. It'd be nice if this was added.

Change History (7)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added
Milestone: CKEditor 3.4

comment:2 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Wouldn't it be better to provide in the docs site (or anywhere else) how to do it using the customization of dialogs without changing the core?

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Doc? added
Milestone: CKEditor 3.4CKEditor 3.x

@alfonsoml, you're right. This is in fact the reason why we don't have DefaultLinkTarget.

comment:4 Changed 10 years ago by Charlie Shehadi

I'm all for that as a solution.

comment:5 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Milestone: CKEditor 3.x
Resolution: fixed
Status: newclosed

comment:6 Changed 9 years ago by tmuikku

Type: New FeatureBug

Well, I can't get it work with the code provided in the guide. It sets the default value alright but the link generated does not have target attribute unless manually alter the target box. One have to edit link.js so that function targetChanged is executed for example in element "linkTargetType" setup method.

comment:7 Changed 9 years ago by Frederico Caldeira Knabben

Type: BugNew Feature

Please open a new ticket for it, as this one has already been closed and released. Thanks.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy