Ticket #543 (closed Bug: invalid)

Opened 7 years ago

Last modified 7 years ago

IE7 does not understand the page-break tag

Reported by: jpghiena Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IE7 Pending WorksForMe Cc:

Description

we discovered that the [page-break] does not work properly when used on IE7.

Read : http://groups.google.it/group/microsoft.public.internetexplorer.general/msg/156c318230ae4d55

We currently use (directly through source code in fckeditor) :

<div style="page-break-after: always; line-height: 0; height: 0px"> PAGE 1 </div> <div style="page-break-after: always; line-height: 0; height: 0px"> PAGE 2 </div> <div style="line-height: 0; height: 0px"> PAGE3 <div>

and then this page-break-after code works with IE7 (yes.... thank you Bill...)

... same code with the page-break-before does not work :-)) (please don't smile...)

Just to let you know that the function "page-break" currently in use in fckeditor does not work with IE7 (or did I miss something ?)

Change History

comment:1 Changed 7 years ago by fredck

  • Keywords Pending WorksForMe added; page-break removed

After some tests, I've found that FCKeditor is actually using "page-break-after", and not "page-break-before", and it is working well with IE7.

I think there is some misunderstanding here. What are you doing to see the problem?

comment:2 Changed 7 years ago by jpghiena

yes, I know, but what is tricky is that the div must have things like "line-height: 0; height: 0px" in it, in order to work everytime... without that, "page-break-after" alone will work... until it does not work :-)) It seems that it depends on some sort of quantity of information used in the PAGE 1 included in the DIV. Well this trick "line-height: 0; height: 0px" works for us until now : but I cannot swear for tomorrow

comment:3 Changed 7 years ago by fredck

Think to note here is that FCKeditor will "never" add content to that div. Well, actually, the Page Break command will always generate the same output:

<div style="page-break-after: always"><span style="display: none">&nbsp;</span></div>

It can't be changed during editing, so I don't see the problem here, as we'll not have such variable content in the <div>.

Are you instead saying that you are going to the source to change things? Is it really a bug in the editor, or a bug in IE7? Also, can you provide us the precise steps to reproduce the problem here, from content creation to printing?

comment:4 Changed 7 years ago by jpghiena

The editor FCKeditor works fine : it generates a proper output.

Then, when you open your final html page with IE7, in some cases IE7 will NOT understand <div style="page-break-after: always">...</div>

IE7 seems to understand everytime <div style="page-break-after: always; line-height: 0; height: 0px">... </div> ; so I am going in the source to change things and add ... line-height: 0; height: 0px... in the DIV.

I have not tried yet with the <span style="display: none">&nbsp;</span> in the DIV, I will let you know.

comment:5 Changed 7 years ago by fredck

I'm a little bit confused... based on your comments, I think you are not using the editor to insert the line breaks (the Insert Line Break button, I mean). What are you exactly doing to insert it instead?

I'm asking it because FCKeditor will "always" insert <span style="display: none">&nbsp;</span> inside the <div>.

comment:6 Changed 7 years ago by alfonsoml

  • Status changed from new to closed
  • Resolution set to invalid

Expired

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy