Opened 8 years ago

Closed 8 years ago

#5433 closed Bug (fixed)

Wrong orientation of Protocol list in Insert Link dialog in Hebrew

Reported by: Satya Minnekanti Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: 3.2
Keywords: IBM Confirmed Review+ Cc: Damian, joek

Description

To reproduce the defect

  1. Open CK Editor Sample with Hebrew Language
  1. Click on Link Icon.

See that the Protocol drop down list box has right to left orientation. However this causes corruption in the order of characters as this should be in Left To Right orientation (because the protocols are in English). Please see attached screen shot

Attachments (5)

ProtocolList Hebrew Error.JPG (23.5 KB) - added by Satya Minnekanti 8 years ago.
5433.patch (1.7 KB) - added by Garry Yao 8 years ago.
5433_2.patch (843 bytes) - added by Garry Yao 8 years ago.
fckeditor_link.png (10.4 KB) - added by Sa'ar Zac Elias 8 years ago.
5433_3.patch (887 bytes) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (17)

Changed 8 years ago by Satya Minnekanti

comment:1 Changed 8 years ago by Sa'ar Zac Elias

Actually all RTL languages are affected.
As a matter of fact, all URL fields should also be in LTR orientation, since links are usually in English.

comment:2 Changed 8 years ago by Sa'ar Zac Elias

One more thing, if this is changed, i believe the order of the boxes should be changed too (i.e. the protocol field should always be on the left of the url field).

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.3CKEditor 3.4

Changed 8 years ago by Garry Yao

Attachment: 5433.patch added

comment:4 Changed 8 years ago by Garry Yao

Keywords: Confirmed Review? added
Owner: set to Garry Yao
Status: newassigned

Provide the ability to declare attributes for select options, while it doesn't make sense to have the entire protocol field layout in ltr just because of it's options.

comment:5 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

While the ability of adding attributes to the options may still bring value to the API, it's still not a solution for this case.

The problem is that, as soon as one of the LTR option is selected, the field still presents it inverted to RTL.

Set the entire field to LTR is not an option also, as in fact we have a mixed situation, as the last option is localizable (see Arabic). I would be curious to hear an opinion from globalization experts.

Finally, the patch still doesn't fix it on IE.

So, let's hold of with this one.

comment:6 Changed 8 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4CKEditor 3.3

As suggested in a message I have from damo, we may try setting the entire select element to LTR. It should be ok for the <other> option, as it would still remain RTL written. The only drawback is that it will remain left aligned, and the combo arrow may be at right. In any case, it's an acceptable solution if it works in all browsers.

comment:7 Changed 8 years ago by Damian

Hi, do we have an update on this ticket?

Changed 8 years ago by Garry Yao

Attachment: 5433_2.patch added

comment:8 Changed 8 years ago by Garry Yao

Keywords: Review? added; Review- removed

comment:9 Changed 8 years ago by Sa'ar Zac Elias

Keywords: Review- added; Review? removed

"&lrm;" is added to the URL after this patch. garry.yao:

it doesn't make sense to have the entire protocol field layout in ltr just because of it's options.

I can't see a reason not to change the layout in this case. It'd make the UI much more comfortable. It was done in FCKeditor previously, Take a look at the attached screenshot.

Changed 8 years ago by Sa'ar Zac Elias

Attachment: fckeditor_link.png added

Changed 8 years ago by Garry Yao

Attachment: 5433_3.patch added

comment:10 Changed 8 years ago by Garry Yao

Keywords: Review? added; Review- removed

"&lrm;" is added to the URL after this patch.

A FF bug/feature really, in IE works quite well.

I can't see a reason not to change the layout in this case.

The problem is that <select> direction should be consistent with UI direction, instead of depending it's options, the v2 approach is plain wrong.

comment:11 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

That's a wonderful solution for it.

comment:12 Changed 8 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5449].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy