Opened 9 years ago

Closed 7 years ago

#5490 closed Bug (duplicate)

[IE] Can't move the cursor after an anchor

Reported by: Sa'ar Zac Elias Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (CKEditor) - OLD
Keywords: IE8 Cc:

Description

There are two different cases affected by this bug:

Steps to reproduce (1)

  • Open the editor and clear all content.
  • Add an anchor.

Notice that the cursor is to the left of the anchor and can not be moved to the right.

Steps to reproduce (2)

  • Open the editor and type some content
  • Add an anchor after the content.

Notice that the cursor is to the right of the anchor.

  • Move the cursor to the left of the anchor.

Notice that the cursor can not be moved to the right.

Change History (2)

comment:1 Changed 8 years ago by Jakub Ś

Keywords: IE8 added; IE removed
Status: newconfirmed

This is still an issue in latest CKEditor.

  • Open the editor and clear all content.
  • Add an anchor.

Cursor will be on the right of anchor but if you move it to the left and try to get back on the right it won't be possible.

This does not happen when there is some text on the right of the anchor

When reproducing this issue I have found #8303

comment:2 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

Scenario two is not applicable any more.

Scenario one has been fixed in let's say older versions of CKEditor but it has reappeared in CKEditor 3.6 rev [6904]

I'm closing this isssue as a duplicate of #7994 as the later has some extra information about problems in Firefox.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy