Opened 10 years ago

Closed 10 years ago

#5512 closed Bug (fixed)

[IE] Can not navigate to the Cell sub menu in the context menu with the keyboard

Reported by: Sa'ar Zac Elias Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: Accessibility Version: 3.2
Keywords: Review+ Cc: satya_minnekanti@…, Alfonso Martínez de Lizarrondo

Description

I was able to reproduce this bug on IE8. I couldn't reproduce it on FF 3.6.5. didn't check other browsers. Tested with the demo and the trunk.

Steps to reproduce

  • Open the demo and put the caret inside a cell of the table.
  • Press SHIFT + F10 to activate the context menu.
  • Go down with the arrow to the Cell option.
  • Open the sub menu using the arrow/tab/space.

a JS error is thrown.

Attachments (2)

5512.patch (876 bytes) - added by brooks 10 years ago.
5512_2.patch (1.2 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.3

comment:2 Changed 10 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:3 Changed 10 years ago by brooks

Keywords: confirmed added
Owner: set to brooks
Status: newassigned

Changed 10 years ago by brooks

Attachment: 5512.patch added

comment:4 Changed 10 years ago by brooks

Keywords: Review? added; confirmed IE removed

I have to say that this is a dirty, unfriend user experiment solution, so this is just a try,if have better method to make IE get the exactly selection,please update it!

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review- added; Review? removed

The problem is that we lose editor selection on context menu, in order to be still capable of reading the selection in context menu, selection lock is invited for that, but for now, the selection is locked only for native contextmenu event, but not existed when using our own keystrokes mapping to trigger the command (SHIFT+F10).

Changed 10 years ago by Garry Yao

Attachment: 5512_2.patch added

comment:6 Changed 10 years ago by Garry Yao

Cc: Alfonso Martínez de Lizarrondo added

comment:7 Changed 10 years ago by brooks

Keywords: Review? added; Review- removed

comment:8 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

comment:9 Changed 10 years ago by brooks

Owner: changed from brooks to Garry Yao
Status: assignednew

comment:10 Changed 10 years ago by Garry Yao

Status: newassigned

comment:11 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5445].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy