Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5558 closed Bug (fixed)

[Webkit] Not scrolling to cursor after paste

Reported by: Garry Yao Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.4
Component: Core : Pasting Version: 3.4
Keywords: WebKit Cc:

Description

Environment

Chrome and Safari

Reproducing Procedures

  1. Open the 'http://ckeditor.com/demo' sample page;
  2. Select all contents then place cursor at the end of document;
  3. Paste with Ctrl-V;
    • Actual Result: The document doesn't get scrolled to the end of the pasted text.
    • Expected Result: The document scrolls to the cursor position, which is again at the end of document. (scrollbar stays at the same position)

Attachments (1)

5558.patch (693 bytes) - added by Sa'ar Zac Elias 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by Garry Yao

This seems to be a webkit bug, where the native 'inserthtml' command (we use for Ctrl-V)doesn't actually scroll to paste content end but scroll to the beginning.

comment:2 Changed 7 years ago by Sa'ar Zac Elias

Keywords: WebKit added; Chrome Safari removed
Status: newconfirmed

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 5558.patch added

comment:3 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

This is definitely a browser bug and it should be reported.

comment:4 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

Please be sure to report it to webkit before closing the ticket, leaving a reference to their ticket here.

comment:5 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Filed a WebKit bug.
Fixed with [5728].

comment:6 Changed 7 years ago by alexanderk

Version: 3.13.4

This Bugfix is not working if forcePasteAsPlainText = true;

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy