Opened 8 years ago

Closed 8 years ago

#5571 closed Bug (fixed)

SCAYT throws error

Reported by: Garry Yao Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Spell Checker Version: SVN (CKEditor) - OLD
Keywords: Review+ Cc: WebSpellChecker.net

Description

Environment

IE and FF

Reproducing Procedures

  1. Open the attached sample page;
  2. Enable SCAYT;
    • Actual Result: JavaScript error thrown.

Attachments (1)

5571_TC.html (4.2 KB) - added by Garry Yao 8 years ago.
Sample page for reproducing

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by Garry Yao

Attachment: 5571_TC.html added

Sample page for reproducing

comment:1 Changed 8 years ago by WebSpellChecker.net

Cannot reproduce on trunk. Seems problem can be reproduced if part of #4836 is not applied.

comment:2 Changed 8 years ago by Garry Yao

Error stack:

invalid range in character class
http://svc.spellchecker.net/spellcheck31/lf/scayt24/_base.xd.js
Line 4765

comment:3 Changed 8 years ago by WebSpellChecker.net

confirm

comment:4 Changed 8 years ago by WebSpellChecker.net

Keywords: Review? added; Confirmed removed

Problem fixed by updating SCAYT core on spellchecker.net side.

comment:5 Changed 8 years ago by Garry Yao

Keywords: Review+ added; Review? removed
Resolution: fixed
Status: newclosed
Version: SVN (CKEditor)
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy