Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5583 closed Bug (fixed)

Problem with CKReleaser source version

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: Project : CKReleaser Version:
Keywords: Confirmed Review+ Cc: Wiktor Walc

Description (last modified by Garry Yao)

Environment

Windows

Reproducing Procedures

  1. Place the attached bat file under 'test' folder of CKReleaser root along with copying ckreleaser.release file from CKEditor.
  2. Replace %ckeditor% with the path of a CKEditor local copy.
  3. Run the script in command line.
    • Actual Result:
      js: uncaught JavaScript runtime exception: ReferenceError "CKPACKAGER" is not defined.
      

Attachments (3)

5583.patch (1.3 KB) - added by Garry Yao 10 years ago.
release.bat (453 bytes) - added by Garry Yao 10 years ago.
5583_2.patch (1.7 KB) - added by Wiktor Walc 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by Garry Yao

Attachment: 5583.patch added

comment:1 Changed 10 years ago by Garry Yao

Cc: Wiktor Walc added
Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

Changed 10 years ago by Garry Yao

Attachment: release.bat added

comment:2 Changed 10 years ago by Garry Yao

Description: modified (diff)

Minor justification.

comment:3 Changed 10 years ago by Wiktor Walc

Keywords: Review- added; Review? removed

The problem is in accessing CKPackager source files.

Although the fix looks good, I'd prefer to avoid adding files that we don't need to CKReleaser repository (we just need CKPackager source files), so I'd vote for leaving external property intact.

Changed 10 years ago by Wiktor Walc

Attachment: 5583_2.patch added

comment:4 Changed 10 years ago by Wiktor Walc

Keywords: Review? added; Review- removed

In the attached patch I've focused on solving _source path issue, I hope it works ;)

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:6 Changed 10 years ago by Wiktor Walc

Resolution: fixed
Status: assignedclosed

Fixed with [5421], [5422].

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4CKEditor 3.3
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy