Opened 10 years ago

Closed 6 years ago

#5639 closed Bug (invalid)

CKeditor 3.2.1. links font size changes when deleting the lines on top with FF

Reported by: Alex Medina Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2.1
Keywords: Firefox Cc:

Description

CKeditor 3.2.1. links font size changes when deleting the lines on top only seen with FireFox.

How to reproduce this problem:

  • paste the html source code in CKeditor textarea (html source provided below)
  • put the cursor right before the link "Forward this to a friend" (at the beginning of the line).
  • select the line above ("also this last ...") with the up arrow key.
  • delete the line you just selected
  • Notice how the link font looks bigger

Below is the html source to test with

<p>

<a href="http://alexmedina.name/link2">http://alexmedina.name/link2</a></p>

<p align="left" id="f2flink" style="font-size: x-small; font-family: Arial,Helvetica,Sans-Serif;">

also this last line in chrom</p>

<p align="left" style="font-size: x-small; font-family: Arial,Helvetica,Sans-Serif;">

<span style="font-family: comic sans ms,cursive;"><a href="http://www.alexmedina.name">Forward this to a Friend &gt;&gt;&gt;</a></span></p>

Change History (2)

comment:1 Changed 10 years ago by Garry Yao

Keywords: Confirmed Firefox added
Priority: HighNormal

Firefox doesn't preserve block styles when merging blocks on 'Backspace', we can do nothing to the bug at the moment because having no managed 'Backspace' implementation.

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: confirmedclosed

It's not a bug. It is an expected behaviour. Browser should only consider semantic as important, because when it starts thinking about styles it is making awful mess, like Webkit and Blink do in #9998.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy