Opened 12 years ago

Closed 11 years ago

#566 closed Bug (worksforme)

Safari: Images disappear on drag and drop

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6
Component: General Version:
Keywords: Confirmed Safari Mac Cc:

Description

When dragging an image already contained in the editor (like a smiley, for example), it disappears on drop.

Switching to source view shows that the image has been moved to the correct place in the code, and the image reappears when switching back to WYSIWYG.

Attachments (1)

image_drag.html (3.5 KB) - added by Frederico Caldeira Knabben 12 years ago.
TC try... but it works on Mac.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 12 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:2 Changed 12 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [726].

Click here for more info about our SVN system.

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: closedreopened

This one is still buggy with Safari 3 Mac. It is working properly on Windows.

comment:4 Changed 12 years ago by Martin Kou

Owner: Martin Kou deleted
Status: reopenednew

comment:5 Changed 12 years ago by Frederico Caldeira Knabben

I've created a TC for it... but it works well on Mac and Windows :| ... I'll be attaching it here.

I've tried loading editing area styles, using relative paths, etc... no way to reproduce the problem outside the editor.

Changed 12 years ago by Frederico Caldeira Knabben

Attachment: image_drag.html added

TC try... but it works on Mac.

comment:6 Changed 11 years ago by Alexey Proskuryakov

Working on a WebKit fix.

I think that a workaround for FCKEditor would be to use complete URLs for smileys (currently, absolute ones such as "/fckeditor/editor/images/smiley/msn/regular_smile.gif" are used).

comment:7 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Confirmed Safari Mac added
Milestone: Safari CompatibilityFCKeditor 2.6

ap, it's great to hear that you have fixed WebKit's bug 14428.

The problem here are not only smileys, but also normal images inserted in the editor, or already present in content to be edited. It is nice to see that you have found the culprit or it. Almost always images are referenced absolutely though. Now we have a chance to try to fix it somehow.

If we'll not have it fixed in a possible Safari 3 public update until the release of FCKeditor 2.6, we'll certainly try to work on it for that release.

comment:8 Changed 11 years ago by Martin Kou

I've tested the bug with WebKit r29955 on Mac OS X Leopard and it seems to be fixed.

comment:9 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed

The WebKit fix will much probably land in the next Safari public release. Currently we have the 3.0.4, which still has this bug.

This ticket can be reopened if the bug will still be present in any future Safari release.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy