Opened 10 years ago

Closed 9 years ago

#5685 closed Bug (fixed)

Undo is broken if there is no instance named "editor1"

Reported by: Alfonso Martínez de Lizarrondo Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: CKEditor 3.3
Component: Core : Undo & Redo Version: SVN (CKEditor) - OLD
Keywords: Review+ Confirmed Cc:

Description

Using trunk with Ajax sample and Firefox:

  • Create an instance, destroy it.
  • Create a new instance.
  • Type something
  • Try to create for example an anchor, an error happens.
CKEDITOR.instances.editor1 is undefined
/ckeditor/_source/plugins/undo/plugin.js
Line 174

Due to [5486]

Attachments (1)

5685.patch (2.0 KB) - added by Alfonso Martínez de Lizarrondo 10 years ago.
Proposed patch

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review? added
Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

The imageEqualsFilters isn't set in any place, the SCAYT plugin is overriding the CKEDITOR.plugins.undo.Image.prototype.equals function, so the changes to the equals function itself seems that can be reverted

Changed 10 years ago by Alfonso Martínez de Lizarrondo

Attachment: 5685.patch added

Proposed patch

comment:2 Changed 10 years ago by WebSpellChecker.net

works for us in trunk

comment:3 Changed 9 years ago by Garry Yao

Keywords: Review+ Confirmed added; Review? removed

comment:4 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: assignedclosed

Fixed with [5501]

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy