Opened 9 years ago

Closed 9 years ago

#5746 closed Bug (fixed)

[Firefox] Selection on form elements

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed Firefox Review+ Cc:

Description

When left clicking checkbox/radio/textfield/textarea, the cursor blinking inside those elements now instead of selecting the entire element.

Form elements are by default editable in Firefox after [5391], it brings issues to us as we intercepts enter key, selection inside such elements is buggy itself, we should restore the previous (when using 'designMode').

Attachments (2)

5746.patch (1.3 KB) - added by Garry Yao 9 years ago.
5746_2.patch (1.9 KB) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by Garry Yao

Attachment: 5746.patch added

comment:1 Changed 9 years ago by Garry Yao

Keywords: Review? added
Owner: set to Garry Yao
Status: newassigned

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
  • The patch fixes the data processor, but we need also changes to the element creation. It will work only if you put the <input> in the source view, but it will still behave improperly if you insert the field through the dialogs and click on it right after that.
  • There is no need to check for <input> of type "text" only. It's safe to have all <input> elements protected. It'll also make the code simpler.
  • Let's have this protection for all browsers, just in case. For example in IE, it's also possible to edit fields if you select the field with a click, then wait a bit, and click on it again (which btw throws an error right now).

comment:3 Changed 9 years ago by Alfonso Martínez de Lizarrondo

This is just an untested idea: I would try to check if it's possible to use some css like -moz-user-modify or -moz-user-input in a way similar to the trick done for IE8 in a recent ticket.

Changed 9 years ago by Garry Yao

Attachment: 5746_2.patch added

comment:4 Changed 9 years ago by Garry Yao

Keywords: Review? added; Review- removed

I've tried '-moz-user-input' with the following exception thrown when moving to the element with arrow keys:

Permission denied to access property 'nodeType' from a non-chrome context

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Unfortunately the change brought no changes to IE, which means we still have a ticket to get fixed now: #5747.

There is just one small change before committing. At line 862, you've used the ", 10" parameter, which is wrong for the on function. The "scope" is expected at the position (not needed in this case anyway). If you wanted to pass the priority, it's not needed also, because 10 is the default value for it.

comment:6 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [5521] on 3.3.x.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy