Opened 7 years ago

Closed 7 years ago

#5757 closed Bug (fixed)

Layout bug in a11yhelp dialog in IE Quirks

Reported by: Sa'ar Zac Elias Owned by: Sa'ar Zac Elias
Priority: Normal Milestone: CKEditor 3.5.3
Component: General Version: 3.3
Keywords: IE IBM Cc: satya_minnekanti@…, jamcunni@…

Description (last modified by Sa'ar Zac Elias)

In IE Quirks the layout of the a11yhelp dialog is corrupted:

  • Content does not wrap.
  • Some of the content is getting out of the box.

Attachments (3)

screenshot.PNG (22.6 KB) - added by Sa'ar Zac Elias 7 years ago.
5757.patch (751 bytes) - added by Sa'ar Zac Elias 7 years ago.
5757_2.patch (1.2 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 7 years ago by Garry Yao

Keywords: Pending added
Milestone: CKEditor 3.4

WFM in IE8 quirks, could you give more info?

comment:2 Changed 7 years ago by Sa'ar Zac Elias

Keywords: Pending removed

I'm attaching a screenshot. I'm using the ui_languages sample from the trunk to verify it is not related to the used language. I don't have any special configuration. All skins are affected.
In the screenshot, note that the content is not wrapped and it is geting below the white line. I'm using IE8 @ Win XP.
Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; InfoPath.2; .NET CLR 2.0.50727)

Changed 7 years ago by Sa'ar Zac Elias

Attachment: screenshot.PNG added

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added

Confirmed with IE8 and the replacebyclass sample in Quirks mode.

comment:4 Changed 7 years ago by Sa'ar Zac Elias

#5994 has been marked as a duplicate.

comment:5 Changed 7 years ago by Sa'ar Zac Elias

#7327 is a dup.

comment:6 Changed 7 years ago by Wiktor Walc

Keywords: IBM added
Milestone: CKEditor 3.5.3

comment:7 Changed 7 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:8 Changed 7 years ago by Satya Minnekanti

Cc: satya_minnekanti@… removed

comment:9 Changed 7 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:10 Changed 7 years ago by James Cunningham

Cc: jamcunni@… added

comment:11 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedreview

After an investigation, the best we can do here is to enable x-scrolling in Quirks.

comment:12 Changed 7 years ago by Garry Yao

Status: reviewreview_failed
  • No horizontal scrollbar is displayed.

It's by design, lines should just wrap.

I didn't see much troubles, the only problem for me is just the height overflow problem, are you sure it affects quirks instead of just IE6?

comment:13 Changed 7 years ago by Sa'ar Zac Elias

Description: modified (diff)
Status: review_failedreview

Yes, IE8 Quirks.

comment:14 Changed 7 years ago by Garry Yao

Do you see "overflow-x" a mandatory for the fix? Again for me it's enough to just keep the height adjustment.

comment:15 Changed 7 years ago by Sa'ar Zac Elias

Unfortunately it seems like this is our only choice.

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 5757.patch added

Changed 7 years ago by Garry Yao

Attachment: 5757_2.patch added

comment:16 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:17 Changed 7 years ago by Sa'ar Zac Elias

Resolution: fixed
Status: review_passedclosed

Fixed with [6600].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy