Opened 9 years ago

Closed 8 years ago

#5861 closed Bug (fixed)

[FF] Error when double clicking on table for first time.

Reported by: Joe Kavanagh Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (CKEditor) - OLD
Keywords: IBM Firefox Cc: Damian, Satya Minnekanti

Description (last modified by Frederico Caldeira Knabben)

  1. Using Firefox, open the Ajax sample and click the Create Editor button.
  2. Click on the Table button to insert a table.
  3. Position the mouse on the table border and double click the left mouse button.

A 'range is undefined' error is thrown at line 183 in the link plugin's plugin.js. See screenshot.

Attachments (2)

doubleclick_err.png (14.3 KB) - added by Joe Kavanagh 9 years ago.
range is undefined error
doubleclick_err2.png (85.7 KB) - added by Joe Kavanagh 9 years ago.
Error on nightly demo

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by Joe Kavanagh

Attachment: doubleclick_err.png added

range is undefined error

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Description: modified (diff)

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe added

I'm not able to reproduce the problem with the current trunk. Can you please confirm it?

Changed 9 years ago by Joe Kavanagh

Attachment: doubleclick_err2.png added

Error on nightly demo

comment:3 Changed 9 years ago by Joe Kavanagh

After further investigating I noticed that to get the error you had to double click on a location where a resize handle or add/delete row symbol would appear. So, for example, double-click on a corner of the table outer border. The table must not have focus before clicking. See the second attachment.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Confirmed Firefox added; WorksForMe removed

Confirmed by double-clicking the table corner.

comment:5 Changed 9 years ago by Paweł Horzela

Owner: set to Paweł Horzela
Status: confirmedassigned

comment:6 Changed 9 years ago by Paweł Horzela

Owner: Paweł Horzela deleted
Status: assignednew

comment:7 Changed 8 years ago by Jakub Ś

Cc: Damian Satya Minnekanti added; damo satya removed
Resolution: fixed
Status: newclosed

I have checked it under latest CKEditor release. Seems to be fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy