Opened 9 years ago

Closed 8 years ago

#5875 closed Bug (invalid)

Java Script in source view breaking the editor while loading..

Reported by: Raghavendra Prasad Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.6
Keywords: Cc:

Description

Hi,

I had entered some data along with some java script in source view.

while loading the data Fckeditor is breaking.

Is there any work around for this defect?

Regards, Raghavendra.

Change History (3)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Pending added
Milestone: CKEditor 3.x
Priority: HighNormal

Please provide the HTML snipped you're loading in the source view. You should also try it with CKEditor 3.

comment:2 in reply to:  1 Changed 9 years ago by Raghavendra Prasad

Replying to fredck:

Please provide the HTML snipped you're loading in the source view. You should also try it with CKEditor 3.

Hi fredck,

will it work with ck3?

even if we add java script as below in source view.

<script type="text/javascript" src="http://www.duq.edu/cmstest/newTemplateTest/index.cfm?type=list"></script>

The editor will break and will not load.

Regards, Raghavendra.

comment:3 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible.

Script pasted in CKEditor will not be executed as it is protected which is by design. But such script will definitely not break CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy