Opened 9 years ago

Closed 6 years ago

#5904 closed Bug (fixed)

dataReady event fires before data is actually ready

Reported by: Wesley Walser Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

When setting content into a CKEditor instance the dataReady event fires before data is actually ready.

If I try to get data out of a CKEditor instance right after the dataReady event fires I sometimes get an empty string.

Change History (3)

comment:1 Changed 9 years ago by Tobiasz Cudnik

Keywords: Pending added

Could you please tell us some more about the conditions when it fails ? Like which editing mode you're into (source, wysiwyg), in which browser it happens or anything that can help us reproduce the issue.

comment:2 Changed 8 years ago by anho

We have the same problem, we are using the wysiwyg editing mode.

If you are using setData(data, callback) the callback should be handled after setData is completed ('dataReady' is fired). Now if you try to getData from the editor the result is empty, we are using a timeout to wait for the data, but that´s no clean solution.

Browser: FF 3.6.12

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: pendingclosed

This issue expired - I cannot reproduce it on FF/Chrome.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy