Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5913 closed Bug (worksforme)

Wrong text updated in firefox 3.6.6 / CKEditor 3.0.1 (revision 4391)

Reported by: jao Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3.1
Keywords: Cc:

Description

when I select a few words in CKEditor and I choose Heading 1 from the menu, the selection disappears and the first sentence gets a heading 1.

Change History (11)

comment:1 Changed 9 years ago by jao

Version: 3.0.13.3.1

I can confirm this problem also exists in CKEditor 3.3.1 (revision 5586)

comment:2 Changed 9 years ago by Tobiasz Cudnik

I assume the main issue you're reporting is disappearing selection ? As "Heading 1" applies to P/DIV elements, depending on enterMode.

In what browser are you experiencing this ?

comment:3 Changed 9 years ago by jao

that is right, the selection is disappearing. Also the cursor disappears. this is in firefox 3.6.6.

I've tested the same code in Chrome and it works there.

comment:4 Changed 9 years ago by Tobiasz Cudnik

I'm not able to reproduce it, does it happens also on our demo site ?

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Pending added
Milestone: CKEditor 3.x

comment:6 Changed 9 years ago by jao

No, it's doesn't happen there.

comment:7 Changed 9 years ago by Frederico Caldeira Knabben

So please provide us a test page which can be used by us to reproduce the problem here.

comment:8 Changed 9 years ago by jao

There's a demo at http://www.jaoord.nl/5913/.

The thing is that the text is de-selected as soon as I hover over the layout drop down.

comment:9 Changed 9 years ago by Alfonso Martínez de Lizarrondo

There are too many libraries in that page.

You should try to remove them to find out what's the problem, because some javascript is executing when the docs is moused over and that seems to make it lose the focus.

comment:10 Changed 9 years ago by jao

Keywords: jquery.layout hover selected selection added; Pending removed
Resolution: worksforme
Status: newclosed

I found out that it was caused by the jQuery layout plugin. More specifically, showOverflowOnHover was set to true. This has to be set to False.

thank you vvery much for your time.

comment:11 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: jquery.layout hover selected selection removed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy