Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#5918 closed Bug (wontfix)

BIDI: [IE8] Paragraphs with dir="rtl" display with resize handles

Reported by: Damian Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Confirmed CantFix Cc: Satya Minnekanti, joek

Description

When using IE8 in non-compatibility mode, any paragraph that has dir="rtl" will display with resize handles.

Tested on nightly build.

Attachments (1)

5918.png (19.0 KB) - added by Damian 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by Damian

Attachment: 5918.png added

comment:1 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added

:/ it looks like we have troubles here... needs further investigation.

comment:2 Changed 7 years ago by Sa'ar Zac Elias

This is a browser bug. hasLayout is true for every element that his layout-flow is different from parent layout-flow (rtl element inside a ltr container and vice-versa), and this property causes the resize handlers to show up. I'm not sure there's anything we can do to fix this.

comment:3 Changed 7 years ago by Alfonso Martínez de Lizarrondo

Keywords: CantFix added
Milestone: CKEditor 3.4
Resolution: wontfix
Status: newclosed

comment:4 Changed 7 years ago by Alfonso Martínez de Lizarrondo

#7159 has been marked as dup

comment:5 Changed 6 years ago by Alfonso Martínez de Lizarrondo

It seems to be fixed in IE10 PP2 (yes, a long way until the final version is released, but it means a future version of IE will behave properly)

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy