Opened 10 years ago

Closed 3 years ago

#593 closed New Feature (fixed)

Start the editor in Source mode

Reported by: anonymous Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc: Alfonso Martínez de Lizarrondo, tallyce@…, ytztech@…, Frederico Caldeira Knabben, olaa81@…

Description

How would I start the editor in the HTML source mode instead of the WYSIWIG mode?

Attachments (2)

593_Proposal.patch (2.2 KB) - added by Frederico Caldeira Knabben 10 years ago.
First patch proposal. Not intended to be the final solution.
593_Proposal2.patch (3.3 KB) - added by OlaA 9 years ago.
Modified proposal

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by Martin Kou

Cc: Alfonso Martínez de Lizarrondo tallyce@… ytztech@… Frederico Caldeira Knabben added
Owner: changed from Alfonso Martínez de Lizarrondo to nobody

comment:2 Changed 10 years ago by Martin Kou

Reporter: changed from Martin Kou to anonymous

https://sourceforge.net/tracker/index.php?func=detail&aid=1294774&group_id=75348&atid=543656 have been marked as dup of this bug


Moved from SF. Original poster: alfonsoml

Has this been implemented? I still can't see anything in the API that allows it?


Moved from SF. Original poster: tallyce

The editor can be started in source mode using the following code (although this doesn't truly avoid starting in WYSIWYG, just the end result is source mode):

<script type="text/javascript"><!--
  function FCKeditor_OnComplete(editorInstance) {
    // Switch the editor from WYSIWYG to SOURCE on startup.
    editorInstance.SwitchEditMode();
  }
--></script>

The FCKeditor_OnComplete function is executed once the editor has loaded. Outside of using this hack in your pages to force the editor to switch on startup, the current editor doesn't support a textmode option by default.

The biggest problem with this scenario is when Gecko or IE "massages" the underlying HTML for purposes not explained by anyone. I know that some fixes for these events already exist in FCKeditor, but it would still be nice to have this function implemented so that the IFRAME initialized with the source active instead of the WYSIWYG view.


Moved from SF. Original poster: ytztech

It�s not possible in the actual version. I�ll manage to include it on future versions.

Best regards, FredCK


Moved from SF. Original poster: fredck

comment:3 Changed 10 years ago by Martin Kou

Type: BugNew Feature

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

Owner: nobody deleted

comment:5 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.7

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 593_Proposal.patch added

First patch proposal. Not intended to be the final solution.

comment:7 Changed 9 years ago by OlaA

Cc: olaa81@… added

Are there any news on when this feature will be included?

Changed 9 years ago by OlaA

Attachment: 593_Proposal2.patch added

Modified proposal

comment:8 Changed 9 years ago by OlaA

I tested the proposal patch on 2.6.4, and modified it a bit to make it work. I've tested it on Firefox, IE, Opera and Chrome. It seems to be working well but I'm not sure it's suitable for a final solution.

comment:9 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy