Ticket #5934 (closed Bug: duplicate)

Opened 4 years ago

Last modified 22 months ago

Scroll on pasting to long block

Reported by: karena Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version: 3.3.1
Keywords: Cc:

Description

  1. Create formatted block
  2. Paste long code (it should be longer then viewport of the editor)
  3. Scroll the content
  4. Copy/paste something -> content will be scrolled

The same behavior for long paragraphs.

Attachments

5934.txt (900 bytes) - added by karena 4 years ago.

Change History

comment:1 Changed 4 years ago by tobiasz.cudnik

  • Keywords Pending added

Could you please provide content of your editor before and after the paste ? I'm not sure i fully understand the case.

I would say that scrolling to end of the paste is a feature, not an issue.

comment:2 Changed 4 years ago by karena

You can use the any css file of ckeditor for example. I've attached the source. Scroll the content to the middle, select any word and try to paste it. The content will be scrolled.

The problem is with styles of pastebin element in clipboard plugin:

top : sel.getStartElement().getDocumentPosition().y

In this case element position is out of the viewport.

Changed 4 years ago by karena

comment:3 Changed 22 months ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to duplicate

DUP of #5549

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy